Deezer Free version - Deezer plays only one song then stops on Deezer Desktop App and Web Version


Hi there

My music is not playing on desktop. It plays one song and then stops. It won't go to the next song. I have cleared cache. Done all that. Please tell me how to fix this. I use the free account and I don't even hear the ads and I don't have an ad blocker. 

Rudi 4 months ago

Hey everyone,

I've merged all similar comments to this thread here.

If you're on a Free subscription offer from Deezer, this is a known issue that is under investigation. If you're on a paid version of Deezer, please let me know - it should be unrelated.

Thank you all for your understanding!

View original

101 replies

https://en.deezercommunity.com/other-devices-49/fixed-music-stops-after-playing-one-song-on-browser-7208

https://en.deezercommunity.com/features-44/deezer-only-plays-one-song-and-then-stops-173

I am having the same issues as these topics created 1 year ago - the website as well as the windows app will only play a single song - but once if finishes the music stops and it will not continue playing anything after. You also cannot hit the next song button once it completes - only can use the play button to continue listening to the same song unless you refresh the page.

website does not freeze - but it just does not function when you press buttons.
I am having the same issue for about two weeks. Tried different browsers as well as the desktop app. Hell, I even used different OS (ubuntu) but the issue still exists. Any solution?
Userlevel 7
Badge +1
Hi @Drixxum @Suf that is strange, we were not able to reproduce this I am afraid. Can you please tell me all technical details such as which Browser you are using, which version of the Browser and which OS and which version of the Desktop app?

Please note that we do not support Ubuntu officially so we are not able to fix problems for this OS.
Hi !
I have the same effect here, after 3 or 4 songs.
I start the flow or my playlist, then the music stops. From there, a click on "Next" simply has no effect.
Going back to the home page and starting over has no effect.
This is both happening on the web site (Windows 10 v.1703, Edge 40.15063.674.0 and Chrome 76.0.3809.132) and with the desktop app. (Windows 10 v.1703)
I even had the following case: the app was "locked" on a song, then I closed the window. Despite this, the music was still playing. I had to manually kill the processes with the task manager.
I could repeat the same bug several times, on several different days.
As a matter of fact, it started for me few months ago.
Thanks for your attention !
Userlevel 7
Badge +8
Hi there @Marcel Tiptop

Sorry that's happened. I've refreshed your cache on our side, and sent a password reset email. Please try changing your password and logging in again, without Google or Facebook for example. Let me know if it helps!
Hello @Rudi !

Thanks for the cache refresh ! It almost worked: the desktop app got stuck on the same track after 7 songs. That's better than 3 😉 but it still gets stuck.
I did not try with the web version, I'll let you know.
Userlevel 7
Badge +8
Thanks for reporting back @Marcel Tiptop!
Have you also changed the password? It surprisingly helps. Keep me posted.
Hello @Rudi

I've changed my password and retried.
Unfortunately, the problem remains.
I'm used now to have the task manager to kill the Deezer processes when the application freezes.
Maybe this helps: I can see the parent process and several subprocesses named "Deezer". They remain even after I closed the application window. It even happens that I can still hear the music playing when there is no open window open at all (but the zombie processes are there :-!)
If you have any idea, welcome ! Meanwhile, I'll kill kill and kill and carry on using your app because I like it !
Cheers !
@Rudi, hello again.
Just an intuition but who knows...
This morning, I had to kill the desktop app five times, after having listened to a couple of songs each time.
After the 6th start of the app, I got the usual commercials ("Get premium etc.") and since then, no freezing !
Could the freezing be linked with the advertisement feature ? I mean, like if the app just waiting for the ad to play, just in vain because the ad server is too funky ?
Userlevel 7
Badge +8
Hi there @Marcel Tiptop

Thanks for sharing with us. I'm not entirely sure if it was that. Because we've been making corrections and improvements as usual. Keep me posted to see if there's any difference in the next few days.
Hi,
Unfortunately, I'm having the same problem; it's been an issue for a couple weeks already.

I use free Deezer. It works fine on my laptop at home (I use latest versions of Chrome and sometimes Edge).
However, it doesn't work on my work computer (same browsers); I suspect there's some kind of issue with sound device settings (even though I'm not sure how it could affect the performance).

UPD: I did try cleaning my cache and cookies (I do that almost on a daily basis). Nothing helps.
Userlevel 7
Badge +8
Hi there @Chibi

Sorry to hear that. Does your work PC have a different OS than the laptop at home? Have you tried using our desktop app on the work PC to see if it's better? It could have something to do with the network as well. Keep us posted.
Hi there @Chibi

Sorry to hear that. Does your work PC have a different OS than the laptop at home? Have you tried using our desktop app on the work PC to see if it's better? It could have something to do with the network as well. Keep us posted.

Hi,

Both work with Windows 10; I still blame sound settings for that (I plugged in my usb speaker once and ever since that moment it's been botched) but I haven't figured out what to do with it yet. Gonna try the desktop app and see how it works, thanks for the tip.
Userlevel 7
Badge +8
Try reinstalling the browsers too @Chibi maybe the configuration has been changed when you plugged the speaker.
Hi there @Chibi

Sorry to hear that. Does your work PC have a different OS than the laptop at home? Have you tried using our desktop app on the work PC to see if it's better? It could have something to do with the network as well. Keep us posted.

Unfortunately, the same problem happened with the desktop application.
Userlevel 7
Badge +8
Thanks for reporting back to us @Chibi

I guess there could be a problem with the network settings at work, for instance. Maybe you use a VPN and there's some conflict there. What does exactly happen? Are you getting an error message?

Thanks for reporting back to us@Chibi

I guess there could be a problem with the network settings at work, for instance. Maybe you use a VPN and there's some conflict there. What does exactly happen? Are you getting an error message?

Not likely; I’m not getting any error messages. Plus, one of my coworkers also uses Deezer and everything seems to be fine on her side. 

Hello!
Since a few days, no more freezing (I’m not talking about the weather ;-)
It all works fine.
There were one or few releases in the meantime if I’m not wrong. They fixed it as it seems.
Bravo and thanks!

Userlevel 7
Badge +8

Hi there @Chibi 

Could you please try updating the app like @Marcel Tiptop mentioned above?

Let me know!

Userlevel 1

Hey, I’ve been experiencing this issue for a week now. Next song won’t start after previous is finished. Song length indicator stops at the end of the current song and nothing happens afterwards. Play/Next/Previous buttons don’t respond. When I reload the web-page or re-open desktop app, song starts to play but issue appears once again when the song is done playing. 
Sidenote: ads won’t play as well. 

I tried clearing browser cache, used other browsers, re-installed app to no avail. Next song just won’t start playing. 

I’ve noticed recently that a lot of people have the same problem. My friend with paid subscription also experiences this exact issue. Any possible solution? Thanks in advance. 

Userlevel 7
Badge +8

Hi there @bart_vader 

Thanks for bringing this up with us. Are you getting any error message? 

I've carried out some maintenance on your account and sent a password reset email. Could you please change your password and log in again, without Google? Let me know if this is happening to random songs as well, please.

And if you're friend with a paid subscription is also experiencing this, please tell them to come to this topic you created so that I can get their details to add to the report too, please :pray_tone2:

Userlevel 1

Thanks for reply @Rudi! I’ve changed my password and loged in without using Google account, but unfortunately it didn’t help. When I play music without shuffle - one song finishes and the next one won’t start. But when I play with shuffle mode ON it plays music until ad is shown(2-3 songs) and then freezes once again. 

What is interesting that I have just an empty white rectangle where an ad should be(in a web player and windows app), but the actual ad isn’t showing. It leads me to believe that this issue is somehow tied to an ad not being shown/played. Feels like it goes on an infinite loop of waiting for an ad, but ad never goes through.

My friend with a paid subscription said that his issue resolved when he re-logged few days ago, sorry for misinforming. 

Userlevel 7
Badge +8

Hey @that_tana_girl 

Thanks for reporting and for your patience.

Could you please try uninstalling the app and put this version here on:

https://www.deezer.com/desktop/download?platform=win32&architecture=x86

Let me know how it goes!

Hey @that_tana_girl 

Thanks for reporting and for your patience.

Could you please try uninstalling the app and put this version here on:

https://www.deezer.com/desktop/download?platform=win32&architecture=x86

Let me know how it goes!

Hi

 

It didn’t work. I have the same problem as Tana and it’s really annoying.

The song stops randomly, any song.

This happens in the windows app and the website.

Userlevel 1

As of now issue seems to be fixed. Thank you!:blush:

Reply