Answered

Stuttering/halting playback both in the browser and in the Windows desktop app


I am using Deezer from Central Europe (Hungary), and in the past few days encountered issues with playback numerous times. The song simply stops for a few seconds or even minutes, likely because it cannot download the next chunk from the server. This theory is supported by the fact that downloading a song has also become significantly slower (once downloaded though, the songs play normally). Seeking into the song helps sometimes, but then it gets stuck again a minute or two later.

Please take a look at the servers serving this area because something seems to be amiss.

EDIT: I’d like to note that all other sites and apps work perfectly, so my own Internet connection is not the issue.

icon

Best answer by pip25 11 January 2021, 16:10

View original

23 replies

Userlevel 7
Badge +6

Sorry to hear that.

Please try to delete Deezer app, reboot your pc, and then install app back.

Also you may want to update your sound drivers or if nothing to update. Delete them from Device manager. After reboot it will be installed again, and you may fix sound problems you have.

With all due respect, that is incredibly unlikely to help. There were no driver or OS updates on my PC in the past few days, and as I said above, the downloaded songs continue to play perfectly - this is not an audio problem. Also, if the Deezer app would be the source, why is it stuttering in the browser as well?

Userlevel 7
Badge +6

I read these forums when I have free time, it seems like no one else posted about this problem.

I use Deezer on Web myself and no problems like this. So anything like clearing cache is worth in help. Also please post your Browser version and App version Windows for Deezer, it will help.

Actually, another similar topic seems to have been opened only a few days ago:

So it’s not just me.

I’m using a Chromium-based browser (Vivaldi), based on Chrome version 87.0.4280, to be exact. The desktop app version is 4.29.0. (But I think that updates automatically, does it not?)

 

Userlevel 7
Badge +7

It does @pip25 

Thanks for coming back.

@hpguru does have a point. Try the following.

  • uninstall the Deezer app and clear your browser's cache and cookies
  • restart your internet router and your computer
  • reinstall the Deezer app from our website https://www.deezer.com/en/download

Let us know how it goes!

Thankfully the issue did not reappear in the past day or two (I did not change anything in my own setup), so I hope whatever was causing it has been fixed.

Userlevel 7
Badge +7

Hey @pip25 

Thanks for letting us know. Please do be in touch in case it happens again, we can only improve the service with your feedback!

Have a great week ahead!

I have been affected by this issue on Windows PC just today. Until yesterday everything was fine. Today, same configuration, but choppy playback with frequent longer halts. This issue is always present with Android Auto.

Userlevel 7
Badge +7

Hi there @Radoslav Galic 

Sorry about that.

Because they're different platforms, could I please have both desktop and Android app versions? Have you tried any troubleshooting so far?

I now deleted my Deezer app with the hope that the stutter will stop. Even my downloaded music on my playlist stutters. I am using an android device

Userlevel 7
Badge +7

Hey @Rox999 

Sorry to hear that. Could you please give us more details? Device, OS and Deezer app version would be useful.

Have you also checked if you have a battery-saver setting on, on your phone?

Deezer is very laggy and keeps stopping today when playing music from the browser. I already cleared the browsing data & cookies but still the same. why is it like this? And I what to use the chrome browser only.

Userlevel 7
Badge +4

Hey @Marbz Mmc do you get any error message it just stops for a bit and then keeps playing?
Does this happens in the desktop app as well?
Thanks 

Badge +1

Sometimes I suffer from the same problem. Apparently the song doesn't manage to download completely and there are small stops (looks like a buffer problem)

I’m having this problem too. Started a couple of days ago. The problem has been troubleshooted to the max. (There are 3 IT guys in my house.) No solution has been found. I’m paying for premium but not anymore.

Sorry Deezer, was loving your service but if I can’t actually listen to the music, I’m taking my money elsewhere.

Same issue, and not consistent. It is driving me nuts. Both the Windows app and webbased (Firefox/Chrome). No audio issues on anything else when it happens either.


I did notice that any input into Deezer is also greatly impacted when the stuttering start happening. It becomes near impossible to adjust the volume slider or skip song / go to a different playlist etc.

Same issue here, on Windows 10. Deezer, this is ridiculous - don’t suggest clearing the cache etc, that’s clearly not the issue

Oh, I was going to open a new issue for this but looks like I’m not alone… (great! =).

I have the same issue, song just pauses for multiple seconds 10 times per song. It started happening a few weeks ago.. it feels like it’s mostly during my work day as well (I’m in New Zealand). Evenings seems to be working Ok which might make sense if it’s a scalability/load issue as Europe wouldn’t consume much traffic at that time. I should add that I’m on a 1Gbps fibre connection and all other services work without issue including 4k streaming video from around the world. There are 0 dropouts on my network connection to various points around the world.

I have tried uninstall/reinstall, clear caches etc. But.. this is happening across all my machines as well as my Sonos devices. Desktop and Web player both have the issues. When it starts happening, Deezer becomes unusable.. as a temporary workaround I have had to start downloading my playlists on my Windows 11 desktop. Of course, that doesn’t work on Sonos.

One question I do have, in all my Windows desktop apps, App Preference just shows Smart Carche as 0 Bytes. There’s no capability to select the amount of cache. Is that as per design? Is the desktop apps not using Smart Cache?

Desktop version: 5.30.310

 

It’s Monday at 12pm in NZ now and Deezer was working 100% until now.. until 5 min ago, then every song I’m playing is stuttering, the song I played now just stopped for 30 seconds. I also noticed the “Your computer seems to be offline message” in Deezer popping up.. which is certainly not the case as I can stream 4k videos through Netflix and Youtube, I have checked and I have 0 network drops to various places using a continuous ping. It’s basically just Deezer that believes I have no internet connection. 

Let me know if I can submit any logs etc. to help troubleshooting!

Userlevel 7
Badge +6

In another thread about web player issues someone mentioned that Deezer uses the customer engagement platform Braze which may be blocked by an adblocker. Maybe try to disable your adblocker in case you use one and check if the message about not being online disappears.

In another thread about web player issues someone mentioned that Deezer uses the customer engagement platform Braze which may be blocked by an adblocker. Maybe try to disable your adblocker in case you use one and check if the message about not being online disappears.

Since I use nextdns.io which includes ad blocking, I had a look and yes, there’s a blocked DNS lookup about every 10th min to Braze. After whitelisting it, I no longer seem to get the offline message since yesterday. Actually, I haven’t had any pauses either but it would be a weird if the connection to Braze would impact the media stream. =) Deezer can work flawlessly for days and then all of a sudden I will have a few hours with constant pauses. I’ll keep an eye on it and will report back.. 

Thanks @bluezzbastardzz !

Userlevel 7
Badge +6

I have also seen that message about not being online in the web player and still had uBlock origin enabled as an adblocker for Deezer which I don’t need as a HiFi customer anyhow. So far I haven’t seen that offline message again since using the web player due to its new gapless playback ability.

Just a quick update. Since I unblocked the connection to Braze a couple of weeks ago, I haven’t had a single playback issue. Sounds a bit nuts that the connection to Braze would somehow interfere with the media stream though?! =)  

Could of course be something else as well.. I think there’s been at least two updates to the Windows app over the last two weeks which could have included fixes for the media issue.

Reply