Deezer x Sonos - Unable to Browse Music

As of last week whenever I try to load the Deezer service within SONOS I keep getting the unable to browse music message. I am using a Deezer premium account and the S2 app all with the latest firmware. I spent an hour with SONOS support and were able to determine it seems like an issue with my Deezer account but I went ahead and did a lot of the recommended solutions I was suggested and found in the forums.


I was wondering if anyone else is still experiencing this issue and if they were able to fix it?


Best answer by awesomemac 6 April 2024, 20:58

View original

18 replies

Userlevel 3
Badge +1

Hi @alanj94 

tried this yet? 👇

Yes I did see this suggestion in the forums before when I was searching, but unfortunately it did not work. Thank you for the reply though!

Userlevel 7
Badge +5

Hi @alanj94,

I'm also using Deezer within the Sonos app S2. 

I'm not experiencing any problems.

Are you able to share a screenshot?

Yes, sorry for the delay, I will attach the screenshots from the mobile app and PC app.

Userlevel 7
Badge +5

As you can see, I don’t have any issues with the Sonos app S2 with Deezer:



Perhaps you already tried this:

-Remove Deezer from the Sonos app

-If you go to the Sonos settings, are you able to reauthorize the Deezer account?


yes, I have tried that numerous times but am still getting the same errors, I made a support ticket and email about a week ago but am still waiting to hear back.

Userlevel 7
Badge +5

Did you send in a request to Deezer of Sonos?

Yes I did, they told me they were going to escalate this to their team and asked me to provide more details and screenshots but I haven’t heard back after sending that information.

Userlevel 7
Badge +5

There will be a new update coming soon from Sonos. Expected date May 7th 2024. 

Sonos Update

I’m experiencing the exact same problem; I’ve deleted and reinstalled the apps; removed and readied the Service into Sonos, reauthorised the service and nothing. I can start something playing via Airplay and can use other services so this is definitely a Deezer issue. 


Userlevel 7
Badge +5

That does not sound well. Hopefully someone from Deezer can pick this up and hopefully this can be fixed.

Userlevel 7
Badge +6

Hi @alanj94 @Andrew Davidson , thank you for reaching out, and a big thanks to our Super User @awesomemac for the help.

All the information has been shared with our developers, and as soon as I have any updates, I will let you all know.

Sorry for any inconvenience caused.

Userlevel 7
Badge +5

This is the new update from Sonos, expected date May 7th


For anyone looking in on this thread it has been confirmed to me by Deezer support that this is now a recognised issue on the Deezer side (not Sonos) and is being looked at. 

Userlevel 7
Badge +5

Please try the new webapp or the phone apps. Out now :) 

Both Deezer and Sonos are bang up to date. Still not working. I chased with Deezer support and todays response is 

“Our team is still working on the problem.
We will inform you as soon as the solution will be found.”

Userlevel 7
Badge +5

As you can see here, the webapp (and iOS) is working fine for me.

I’m very sorry that this isn’t working for you 😒


The new update seemed to have fixed it for me as well, it’s working as expected.