Deezer will no longer work (blank screen) on Chromecast Gen1 (everything else does)

  • 5 September 2022
  • 5 replies

When trying to cast to a Chromecast first generation device, I am now getting a blank screen. 

Deezer support suggested I contact Google! They are not likely to be interested since…
- every other app (BBC iPlayer & Sounds, Amazon Prime, Netflix, Youtube, etc etc) works fine, so they are almost certain to say it’s a Deezer problem.
- I have observed the same problem on a completely different phone.

This is pretty much a showstopper – and follows other “niggles” with Deezer in the past.
I’ve been loyal to Deezer in the face of offers from Spotify, Tidal and Amazon music, but I think it may be time to make a move :-( 


Best answer by Yula 6 September 2022, 15:09

View original

This topic has been closed for comments - the content may no longer be relevant or up-to-date, so please search for keywords so that you can find a newer post or look below for a direct link

5 replies

Userlevel 7
Badge +10

Hey there @SuffolkTyke

From which device to which device are you Casting? 

Can you check you are doing everything correctly from this article?

I am getting the same result using muiltiple devices (Xiaomi POCO, PIXEL, iPad) and as explained before I am casting to a first generation Chromecast - which gives me no problem with every other casting app. 

Yes, I’m absolutely sure I’m doing everything right - I’ve been using / setting up Chromecast devices since they were first introduced. And I have been using Deezer with the same device and setup for a couple of years or more. 

But to be sure, I deleted/reinstalled Deezer on my mobile device, and factory reset / recommected the Chromecast device. The result was the same, a blank black screen on the Chromecast display.  


Yeah, this does not work for 8 months. It would be nice if Deezer was open about that.

Userlevel 6
Badge +5

Yup, broken since February. Oddly though I was able to cast to my Chromecast Audio today for the first time in months. 

Unfortunately, as of today, still the same issue with my gen 1.