Yamaha MusicCast Firmware Update & Deezer


Userlevel 2
Badge +1
Yamaha blasted out a new firmware update a few days ago. For some reason now, Deezer will not play well with all my Yamaha gear.

I have 4 WX010, 1 WX030 and a WXA50.

When I link any of them together none of them sync up. The music is delayed a good 1 second. The only way to remedy the situation is the pause the track, then hit play again. BUT when the next song plays there is a delay again....

This wasn't the case before the firmware update. Before the update Deezer was flawless on Musiccast.

Also, it appears my spotify service works just fine but I haven't had much time testing that service out. Only a few minutes. But in those few minutes it worked fine.

I have a feeling the new speaker firmware isn't jiveing with the app and it's services API?

Is anyone else experiencing this?

Denis Nedilyuk 7 months ago

Hi @Denis Nedilyuk thank you for contacting us. Please bear in mind that this is a very old thread from 2018. 

Could you please explain in more detail which technical problem you are currently experiencing?

Could you please let us know whether you updated your Yamaha software or you mean the latest Deezer versions? 

Thank you :slight_smile:


Hi

I have Yamaha AVR RX-V483, as the main device, and WX-010, ISX-18 speakers in the multiroom ecosystem. MusicCast is running on my smartphone Huawei Mate 20 pro. Everything FW and SW is updated to the latest versions.

Sometimes, while listening to the Deezer on the AVR (doesn’t matter if the satellite speakers connected)  the playback suddenly stops, and the display just shows the word “Deezer” instead of the name of the song. To resume playback I need to open the MusicCast app and push the Play button.

This happens only when Deezer is selected as the source and I can’t say that there are any prerequisites for the crash. The playback is Ok when the source is NET radio or the server or smartphone itself.

It would be really really nice to have the possibility to stream the music directly from the Deezer app to the Yamaha devices, but not from the MusicCast

BR

Denis

View original

49 replies

Userlevel 5
Badge +1
Thanks for pointing this out! Let's first see if there are other people experiencing this - I'll keep an eye open on our other contact channels as well 🙂
Userlevel 2
Badge +1
I talked with Yamaha tech support and went thru all troubleshooting. Nothing worked. I went as far as doing factory resets on all my Yamaha gear.

Before the firmware update Deezer was perfect. After the firmware update not so much. I actually can't even use Deezer because the delay in sound between each speaker is that noticeable.

They are supposed to call me back on Monday.

Spotify, Siriusxm and online streaming channels work just fine.

I really hope other people have this issue so it can get fixed.
I am having problems also with MusicCast and Deezer. Mid-streaming, the audio will stutter then drop out. Wont let me log back in. I have to disconnect from power source, apparently to reset all connections to Deezer.

Also, the MusicCast app doesn’t retain the Deezer login credentials and I have to type my credentials each and every time I want to use Deezer. Big hassle. I want to be able to just click on Deezer as my source and go! Can this be corrected somehow?
Userlevel 2
Badge +1
I am having problems also with MusicCast and Deezer. Mid-streaming, the audio will stutter then drop out. Wont let me log back in. I have to disconnect from power source, apparently to reset all connections to Deezer.

Also, the MusicCast app doesn’t retain the Deezer login credentials and I have to type my credentials each and every time I want to use Deezer. Big hassle. I want to be able to just click on Deezer as my source and go! Can this be corrected somehow?

What yamaha gear do you have? Do you have wireless speakers? Or an amp? Both? Did You update the musiccast firmware on the speakers/amp?

It's not an app update.... It's a firmware update on the actual hardware of the speakers/amp.
Userlevel 2
Badge +1
Just as a follow up to my original post.

I have been in contact with Yamaha US. They have confirmed that my problem DOES exist and that Yamaha US is reaching out to Yamaha Japan to let them know and do an update ASAP.

It would be good if anyone from Deezer could put pressure on them too. Just so they get hit with request from both sides.

Just so Deezer is aware, you could potentially lose customers because your services is rendered useless with the new Yamaha firmware update if running multiple linked speakers.

Luckily for me I have Spotify too.... But I really want to cancel and just keep Deezer. I can't until this is resolved.
Userlevel 2
Badge +1
Email from Yamaha

Badreligion91,

I was able to stream about 4 songs on your Deezer account, and sure enough, the linked speakers went out of sync with the master unit. The linked speakers stayed synced with each other, but the master unit was ahead by a second or so. Like you, I can not duplicate the problem with other streaming services like Spotify.

I'm going to report this to Yamaha Japan today. My hope is that they will release another firmware update that fixes this, and a few other issues we're encountered since the update. In the meantime, I can only suggest using a different streaming service unit we get this sorted out.

Yamaha support
Userlevel 5
Badge +1
@Badreligion91 uhhh, that sounds like a step towards a fix! Cool, thanks for sharing this. Will you keep the community updated on this? That would be great! 🙌🏼
I play deezer via music cast app. All wired - not WiFi!! , suddenly randomly the song pauses . When I press play deezer app jumps to the next song.
this problem started a week ago. No changes made at that time from my end.
please advise
thanks
Yaniv
Userlevel 2
Badge +1
@Badreligion91 uhhh, that sounds like a step towards a fix! Cool, thanks for sharing this. Will you keep the community updated on this? That would be great! 🙌🏼
Shannon do you work for Deezer in some capacity? If so, can you also help by navigating your PR channels to have Yamaha get on this ASAP?

To me, this isnt just a simple oops. This is a major problem.... Maybe even world wide.
Userlevel 7
Badge +1
@syaniv I moved your topic into this one, can you take a look at the conversation above to see if it's a similar issue? @Badreligion91 has been a great getting information with Yamaha's team, take a look and it might help 🙂 If it's not the same issue, give us a bit more info of what's happening and what devices you're using.
I'm not sure if it could be the same problem, but there is also the issue of Deezer going randomly into pause / stop during the playback of music in Yamaha through their MusicCast app.
Userlevel 2
Badge +1
I'm not sure if it could be the same problem, but there is also the issue of Deezer going randomly into pause / stop during the playback of music in Yamaha through their MusicCast app.
I am also having the same problems but I'm trying to see if its just when I use "flow".

Is it happening when listening to play lists? Or flow?
To me happens with flow, playlists or albums. As albums as usually smaller (in number of songs) than playlists, sometimes I manage to get the full album without any problem, but I already had it happen with at lest one.
Userlevel 5
Badge +1
@pamaro alright... and which devices are you using exactly? 🙂
It is the Yamaha MCR-N870 (a bundle of the A-U670 amplifier with the CD-NT670 receiver). The MusicCast app (Android) connects to the receiver via wifi.
Userlevel 7
Badge +1
It is the Yamaha MCR-N870 (a bundle of the A-U670 amplifier with the CD-NT670 receiver). The MusicCast app (Android) connects to the receiver via wifi.

Hi there, just checked the conversation here. So did I understand it correctly that it always cuts/ stops after a while of playing? In that case, is there a setting for a sleep mode or battery saving mode for the device?
Could be that it switches to sleep mode after a while and cuts the connection to Deezer.
I had that doubt as well in the beginning so I made sure all sleep modes of the yamaha were turned off. So that does not seem to be the issue. Also please note that the yamaha does not go to sleep or turns off. The music simply stops playing. And it is never after an exact amount of time. It is very random. I got it after a couple of minutes after starting a playlist and / or after several hours of continuous playback. I also get the pause in random amounts per playlist (never, once or several within the same playlist, some time a few in a row, most time with several songs in-between). It is really a random situation.
Userlevel 7
Badge +1
Hi @pamaro thanks for all the details. We will pass this on internally and keep you posted if we have more info, but it looks like Yamaha needs to fix it.

Can you tell me what firmware you have on your Yamaha soundsystem?
The firmware is 2.06

I do not know if it is a yamaha problem. Spotify and internet radio work fine.
It may be a problem of the deezer integration into musiccast or maybe some problem in the synchronism between yamaha and deezer servers. But even if the problem is with yamaha, i am sure some pressure and help from deezer to yamaha will work wonders.
Userlevel 7
Badge +1
The firmware is 2.06

I do not know if it is a yamaha problem. Spotify and internet radio work fine.
It may be a problem of the deezer integration into musiccast or maybe some problem in the synchronism between yamaha and deezer servers. But even if the problem is with yamaha, i am sure some pressure and help from deezer to yamaha will work wonders.


We've passed this on to our team and they'll look into it and if needed, will get in touch with Yamaha :)
Thanks for your feedback, pamaro!
I’m experiencing all the same issues described above. I did update to the latest firmware today.

I have 2 Wx-030’s (paired as stereo) in my bedroom and a WXC-50 on my home audio system in the living room. There’s a terrible lag between the WXC-50 and the two wx-030’s. Also, when I’m playing just the 30’s in the bedroom, after a a few consecutive songs, the left unit drops the audio. It’s still paired and the buttons control volume and pause/play for the other unit that remains playing. I have to disconnect the power source and then plug it back in and it will resume playing. It’s reliably unreliable.

I really hoped the firmware update update would have fixed this.

ps using Deezer. Doesn’t seem to happen with internet radio.
forgot to mention that I am also using Deezer. Haven’t noticed the problem with internet radio.
Userlevel 5
Badge +1
@Jeffwasheretoo we're currently awaiting a reply from Yamaha - will keep you posted here 🙂
Userlevel 2
Badge +1
Hi everyone

As a follow up to my original post. Yamaha did put out a new firmware to help with the syncing issues. This was firmware 2.08. This is good for all speakers but not amps or receivers. Amps and receivers got another firmware update a few days later... That is 2.58

I believe there is still work for Yamaha to do. The syncing issue has somewhat been resolved however at the beginning of each song there is a delay but then the speakers sync up. It's somewhat annoying and not nearly as smooth as firmware 2.06

SiriusXM and Spotify do not have this issue.

I also am having a problem with music just randomly shutting off or pausing. It can be 1 song in or 50 songs in. It doesn't matter. This never happened before. Not sure if it's firmware or App update that messed that up.

The guy from Yamaha I'm dealing with is helpful and was partly the reason the new firmware 2.08 was issued. The more people emailing tech support or calling tech will help rectify the issues we have.

The summer months are upon us... I want my music to work!
Userlevel 2
Badge +1
The firmware is 2.06

I do not know if it is a yamaha problem. Spotify and internet radio work fine.
It may be a problem of the deezer integration into musiccast or maybe some problem in the synchronism between yamaha and deezer servers. But even if the problem is with yamaha, i am sure some pressure and help from deezer to yamaha will work wonders.

Firmware 2.06 was the most stable with Deezer so it probably has to do with the latest App update.... Process of elimination. I suggest NOT updating firmware on your speakers if possible.

Reply