Answered

Sonos - ALL songs skipping after about 50 seconds of play (both flow and playlists)

  • 29 January 2019
  • 96 replies
  • 4300 views

Userlevel 1
My sonos speakers have been working flawlessly with deezer up until this week or so. Now i have every song skipping after about a minute or so of play, regardless of it being flow or from a playlist. Sonos app just says "lost connection to deezer"
icon

Best answer by Steveellis 24 February 2019, 09:17

Update. So my issue of skipping only seemed to occure when I requested Alexa to play the music in the dining room via my Sonos beam in the lounge. Called Sonos and they advised to go to my Alexa app. Go to the skills section. Disaasiate the deezer skill. Leave for 30 seconds or so. Then re learn the deezer skill. This, for some reason, seems to have solved my issue.
View original

96 replies

Userlevel 7
Badge +5

Hi there @Isaac2 

Thanks for reporting it to us. We're keeping an eye on this issue and our devs are working on it, please see here for further updates :thumbsup_tone2:

I’m having this issue on all my Echo devices here in the UK. It will play part of a track then skip. Is there still no known fix for this?

Userlevel 6
Badge +3

Hello @patanddean, thanks for getting back to us and letting us know about this, that’s very much appreciated and hopefully it will help other users as well! 

Have a nice weekend :slight_smile:

I also contacted Sonos, and after much resetting and rebooting, it seems my wi-fi signal was not strong enough and connecting one speaker by Ethernet cable to the router solved the problem. Pat

Userlevel 6
Badge +3

Hello @patanddean and @Bill Stoyles, thanks both for your feedback, we’ll forward it to our teams. Sorry about the inconvenience!

Cheers

Deezer songs are skipping the last 10 seconds on each song. I have followed Rudy’s instructions to the letter and it made no difference. I really enjoy Deezer, both the sound quality and selection and have no idea how to replace it. This has just started in the last few days.  Please help. Pat

Yes, I have done that many times, purchased a boost, and wired in more speakers. My internet speed is 150 and network runs on fairly high end routers. No issues with any other streaming, video or audio. 

Userlevel 6
Badge +3

Hello @Bill Stoyles, I’m sorry to read that you’ve experienced so many issues with the integration of the Deezer app to the Sonos system. Have you tried the troubleshoot mentioned by Rudi just above?

Have a nice day

I have a fairly large Sonos system for a number of years now, but Deezer is completely unreliable with it. I recently added Amazon Music and no issues at all. Don’t have any problems with Deezer app, but integration with Sonos is not working - constant track skipping. This has been happening on and off since I got the system, but the last couple of months have been absolutely awful. Can’t listen to any Deezer tracks/playlists through Sonos without skipping. I bought Deezer for its Sonos compatibility - without that, I won’t be staying on as a customer. 

Userlevel 7
Badge +5
Hi there @Jjljerry

Have you tried unlinking your Deezer from your Sonos, then switching off the Sonos and your internet router for about 3 mins and restarting? Then link and authorise your Deezer account again.

It's important to check for updates on your Sonos app too. Let me know if it helps 😉
Have Deezer hi fi. Song starts and stops in 5 seconds or so and tries next song. Error says network speed too slow for buffer. Spotty and pandora work fine. Tried reloading app, reauthorize sinus etc. Deezer worked perfect last year. Just started subscription again and no saved playlist or songs work. Nor do new songs trying to play from Deezer. Ready to cancel.
Userlevel 7
Badge +5
@woodroll

Thanks for sharing it!
For people having this problem with a decent sized Sonos system, the high bit rate provided by Deezer may be overloading the Sonos wireless signals. I had this problem. When I restricted playback to either a single set of speakers or only to wired speakers, the problem quickly went away.

With my system, there were several rooms running wirelessly (i.e. no wired connection)...In a couple of the rooms, I had access to wired connection, but never deemed them necessary (since I never had playback issues with other services). Once I wired them and reduced the total number of speakers running wirelessly, all was good!
Userlevel 7
Badge +5
@Steveellis

Legend! Thanks for sharing, hopefully it can help more people 😉
Update. So my issue of skipping only seemed to occure when I requested Alexa to play the music in the dining room via my Sonos beam in the lounge. Called Sonos and they advised to go to my Alexa app. Go to the skills section. Disaasiate the deezer skill. Leave for 30 seconds or so. Then re learn the deezer skill. This, for some reason, seems to have solved my issue.
Userlevel 7
Badge +5
Hi there @Steveellis

Thanks for the input and detailed info, I've passed this to our devs. We'll get back once I get an update.
So I have progressed with my music skipping issue. I have a Sonos Beam in my living room. I instruct Alexa to play music in the dining room where I have a Sonos connect and my old audio system. The music from Deezer begins. It is skipping regular. So, whilst in the dining room, I start the Sonos app on my iPhone. I then get the message appear on the app 'unable to play set fire to the rain the connection to cdnt proxy d.dzcdn.net was lost '. The music skips, next track begins and so it goes on with message appearing.
Now at this time I search on the app for Adele/or whatever and the interupt the playlist playing music selected on the phone . From then on the music does not skip. If you can assist as to why this is occurring I would be grateful. Incidentally my router is in an upstairs room and all wireless.
Many thanks. FYI I logged out and deleted Sonos app. Reinstalled the app. No difference whatsoever. I then used amazon service for the last two evenings without issue. For second evening I started on deezer and it skipped then went to amazon.
Userlevel 7
Badge +5
sorry about that! Our developers are in touch with Sonos and hopefully it will be fixed soon! We will keep you guys updated!
Are you saying log out of Deezer. Delete the Sonos App off my mobile then reinstall the app. Sorry if I’m a bit techno thick
Userlevel 7
Badge +5
Hi there @jon.spinks @Steveellis

It's supposed to be resolved. Could you please try to log out and reinstall the Sonos app to the latest version?
Keep me posted!
Hi. I am a Virgin media customer. Last few days same issue as many others. Tracks skipping mid song. I have a sonos beam with a sonos connect in another room. Whilst listening to the music via the connect my iPhone app suddenly says 'unable to connect to deezer' There is more to that message but it disappears so fast. I then hear the next track so I know I am connected. Plus it worked fine from November to mid January. Please assist. I have an amazon account and I will see if I get same issues.
Userlevel 7
Badge +5
Hey there @jon.spinks

Sad to hear that...
But thanks for the feedback! I'll pass it on to our devs.

If anyone else is experiencing the same, please keep me posted.
Hi there loyal and gorgeous people,

I've been informed that some amendments were made in hope to fix what you've been experiencing with Sonos. Could you all restart your systems and give me an update?

Thank you!

It's back again this morning Rudi. I had a couple of days with no issues but it's come back, just less frequently. Once every 3-4 songs now.
Userlevel 7
Badge +5
Hi there @Mikefitz @dfarrington

Sorry to hear that.
Perhaps you should try switching off both the device and the router for around 3 minutes and then try again! Let me know if it works 😉

Reply