Question

How to fix "Error: Failed to play. The requested content is not loading" on desktop.

  • 1 November 2021
  • 3 replies
  • 55 views

  • One hit wonder
  • 2 replies

I have tried to play music through both the web browser and the windows 10 app and neither will play a single song. Have restarted my laptop multiple times, cleared internet cache, reinstalled the app itself about ten times and i have yet to hear one second of a single song. It's been a week and I'm sick of it. 


This topic has been closed for comments - the content may no longer be relevant or up-to-date, so please search for keywords so that you can find a newer post or look below for a direct link

3 replies

Userlevel 7
Badge +5

Hey @Soul 

That sounds strange. Do you have problems with other programs or only with deezer?

Please uninstall the deezer desktop app once and download the latest version directly from the deezer server:

https://www.deezer.com/desktop/download/artifact/win32/x86/5.30.90

 

Which browser do you use? Did you change anything there? Adblocker or VPN active?

@dee_dirk Nope. Everything else runs perfectly and haven't had any issues, the laptop is only a few months old. Downloading it again won't do anything, as I've already completely reinstalled with the latest version several times today alone.

 

Alright, tried using your direct link and nothing has changed. Any other ideas? 

I use Google Chrome. No active Adblock or VPN.