Answered

Deezer sign in problem with Astell & Kern Digital Audio Player


I have just bought an As tell&kern SP2000 Digital Audio Player.

 

I tried many times, but the SP2000 didn't allow me to sign in the Deezer app. Is there any existing glitch for the AK DAP with 5he Deezer app?

 

What can I do to resolve this problem?

 

Thanks,

Simon

icon

Best answer by calagran 10 June 2021, 10:40

Sure,

I downloaded the latest apk file from here

 https://deezer.en.uptodown.com/android/download

Then followed these instructions

https://bloomaudio.com/blogs/articles/installing-apps-on-your-astell-kern-dap

 

Hope this helps.

View original

19 replies

Userlevel 7
Badge +8

Hey, Simon @scheng49 

Thanks for reaching out. Which app exactly are you trying to log in to? Could you please specify the version?

Are you getting an error message? Could you please take a screenshot for us to see a bit better?

I've carried out some maintenance to your account and sent a password reset email. Change the password and restart your devices, including the network router, to see if it works.

Trying to log in through embedded Deezer service / application from A&K SP1000, getting “Data provided is incorrect. Try again”, though the same credentials work ok on desktop or smartphone.

A&K SP1000 firmware version 1.57 CM. So far could not find showing Deezer application version anywhere.

Userlevel 7
Badge +8

Sorry about that @svjoy please try changing your Deezer account email to see if it helps, together with restarting your network router and devices!

Keep me posted :relaxed:

Hello @Rudi

Tried chaging email, but still same situation - can’t login from A&K SP1000 player, but successful login from PC (web browser and application) and android mobile (application). Can you check please if it is some restriction on Deezer side? Like Android version etc.? As I heard, A&K devices use Android internally, though can’t say for sure. Are my authetication attempts from SP1000 (firmware version 1.57 CM) at least visible on your side?

Any hope /information that firmware A&K are going to release in May (which is generally expected to solve some authetication-related  issues) will help?

Is there any way to try to (re-)install Deezer manually on A&K? For android, apkpure says page is deleted. https://apkpure.com/deezer-music-player-songs-playlists-podcasts/deezer.android.app

Error 410 - Page Deleted or Gone

APK from ​https://techbigs.com/?s=deezer solves the authentication issue on SP1000 even on March’21 firmware 1.57CM. Instructions in parallel thread 

Installed application shows up separately from embedded one, and unlike embedded shows version (currently downloaded and installed 6.2.26.58).

Userlevel 6
Badge +2

Hey @svjoy I’ve contacted our developers and they mentioned that the issue comes from the onboard browser on the device. This is an issue on Astell & Kern side and you can contact them for any further information regarding new firmware and a fix to this problem.
Apologies for the inconvenience.
Thanks :)

Hello!
I just bought Astell&Kern SR25 and cannot login the pre-installed Deezer App:

1) Via e-mail

Using the same cridentials as on other deviced it says that the cridentials are wrong.
I tried many times, changed password, succeeded on other devices.
SR25 always says about the wrong cridentials, try again.
 

2) Via Apple or Google account buttons

It doesn’t ask any cridentials, but says “You are logged in a free account. This service is only available for premium accounts.” and redirects to the Start Deezer page.

3) Via Facebook button

It shows the Facebook login page, but when I try to log in says “Logging into this app with Facebook is not available at this time”

The pre-installed Deezer App on Astell&Kern SR25 doesn’t login at all.
 I have installed 6.2.23.100 somehow. It works, but crashes when I try to open Audio Settings.

I have the same problem with S&K SP2000.

S&K Deezer version 0.8

It worked on the SP2000 as delivered but later upgrades seem to have created a problem.

Firmware upgrade to 1.41CN did not solve.

I will try the spk for the latest Deezer version to see if this solves.

I installed Deezer  apk 6.2.27.47 from Deezer on A&K SP2000 as a second Deezer app

Full access for HiFi streamingwith storage option.

A&K Deezer app still available but i cannot log in

SP2000 firmware 1.41CN

I am having the same problem with the imbedded app.    It has to do with the AK device automatically logging into the free account.    When you put in your premium or hifi password, it gives the error message that you are already logged into the free account.   No way to log out of the free and get into the premium.

Userlevel 7
Badge +8

Thanks for reaching out and for the feedback @jpk_77 @cardstock @Pavel Lutsenko any way a fresh reinstall can do the job? Have you had any firmware update recently?

I'm wondering if you could change the email address for the Deezer account to see if it helps. Keep us posted!

I purchased the AK SR25 with the 1.4 firmware.   It is now updated to 1.54.   No difference. 

It won't permit free login with Apple, FB, or Google.   My Deezer account is, and alway was since the first login, HiFi.  

I also tried to load an external App to do it and it crashes and will not even finish booting.  

Very frustrating as I want to stream mindless and diverse and new music and I really want streaming to my AK.    I really wish I knew if it was an authentication problem on Deezer’s end or a glitch in the AK operating system.   Maybe time for some emails to both parties.   

Hi Rudi

Yes problem may have started with a previous firmware upgrade and is not corrected by the latest firmware upgrade to 1.41CN.

Clean install of integrated Deezer might work but preinstalled by A&K. Not willing to try as player working well and .apk of Deezer working for me with full functionality.

Tried new email for free account and I get a message that preinstalled Deezer for premium Deezer account only. 

Tried google log-in and I get amessage that preinstalled Deezer for premium Deezer account only.

Did not try preinstalled Deezer with.new premium account as not willing to set up a second premium account to try.

Hi all,

Brand new to the platform and straight away run into a problem. I cannot login to the preinstalled app on my Kaan aplha. I checked my login credentials numerous times, but alas I cannot login because my ‘’details are incorrect’’. Any ideas? TIA

Any updates? I also facing this problem with unable to log on sp2000 saying about my account is free 

This might solve the problem. I just downloaded a Deezer apk file which I side loaded into the services folder and now I’m up and running.

Userlevel 7
Badge +8

Hey @calagran 

Thanks for letting us know. Could you please share more details about your workaround here with us?

Perhaps it can help @travisds @jpk_77 @cardstock 

Sure,

I downloaded the latest apk file from here

 https://deezer.en.uptodown.com/android/download

Then followed these instructions

https://bloomaudio.com/blogs/articles/installing-apps-on-your-astell-kern-dap

 

Hope this helps.

Reply