Error MS2004

  • 2 December 2022
  • 45 replies
  • 2125 views

Why am I constantly getting this error? Tried everything from troubleshooting..

Driving me insane! 
 

 

Johnathan.Deezer 6 months ago

Sorry about it guys. Our developers team know about this issue, they are working on it again as the cases increase and I hope they can solve it on the following weeks sending an app update as soon as possible. 🤞🏽

Take care.

View original

This topic has been closed for comments - the content may no longer be relevant or up-to-date, so please search for keywords so that you can find a newer post or look below for a direct link

45 replies

Hi 

I’m having the same problem. I have done the ‘clear all’, ‘empty cache , bla-bla-bla and still not working with some tracks. I come across that problem more often these days. I have been with Deezer for years so please hurry up sorting it out.

Getting this same error, not happy this has not been fixed by Deezer. Been with them a long long time but if they don’t sort this soon I may move to another provider.

Userlevel 1

I have been getting this error for over a month on iOS 16.1.1-

Occurs when searching for a song, first song selected will play and launch a track mix but searching for a second song or selecting another search option brings up this error.

Can then listen to next song by quitting and relaunching app.

 

Solution would be great as this vastly limits user experience and functionality. I agree with previous commenters that it is not fair to pay for a complete service that we are not receiving.

It is happening to me and it is only certain songs not all, I did all the steps you gave and it has not worked. This only started happening AFTER an update to the app so I think someone has buggered up some of the code and is loathe to find it and fix it or cannot find what they have done! With the price increased on my membership we should be getting excellent service to cover this, if I cannot even listen to half the songs I search for then what the hell am I paying for! We should get some of the membership back as consolation for these last few months, its been since before Christmas I know that for sure 

I’ve been trying to get this problem fixed with Deezer support since I posted the above… sad to say they haven’t a clue what’s going on. 

I find it hard to believe it’s only affecting a few users. I’ve subscribed to Deezer for years, this is a new problem that’s started happening consistently, what am I doing that’s different to anyone else? No one seems to know. 

Why does the code MS2004 keep coming up when I’m trying to play certain tracks?? I pay a monthly subscription to Deezer, this isn’t acceptable, it’s very frustrating.

I’ve deleted the app and reinstalled, but still having the same issue.

Userlevel 1

( Having just asked, others in my family are experiencing this same issue while using search)

Hello,

 

I am also having the same issue for months, I’ve tried all steps advised - Clear cache, deleting app, restarting phone and downloading app. Nothing works!! What’s even more worrying is that we have our wedding in a couple of months and trying to sort out playlists for the day which is a nightmare to try and do with this error and even more worrying if this happens on the actual day!!! 
 

As everyone says, why are we paying £15 a month when this issue doesn’t seem to be getting resolved?! 
 

I’m now looking at other suppliers/platforms 

So it seems I’m one of many , if not all subscribers getting the same error.

 

Can’t keep telling us your “working on it “ , how about a refund ?

Thanks. 
Just to understand, the problem only occurs when you are listening with airpods from the apple watch?
 

It only happens when listening to music on my iphone using my airpods while i am wearing my watch. I’m not playing music from the watch.

 

cheers,

 

Steve

I’m getting exactly the same problem as the screenshot showing the error message. I’ve tried deleting, reinstall, clear cache etc, still happening  randomly. Works just fine, then doesn’t. 
It’s getting annoying. 

I’ve been getting this problem since before Christmas that’s how long it’s been going on for definitely not acceptable especially after putting prices up when they know about the problem 

Userlevel 1

Hi @Johnathan.Deezer-

-My user ID is Golden Nuggest
-I use a family plan (though I use my account the most I don’t believe others on my plan are experiencing this issue)
-Streaming from Scotland
-Error occurs using search function

Thank you, I would like to fix this as quickly as possible

  • Your user id. Billymcgann 
  • Your offer (Premium, Family...) family 
  • main country / country where you streams (in case is different) Scotland uk 
  • played context (Track mixes? search? playlist?...) happens on tracks that have not been downloaded, if I get the error but download the track it plays fine

@Johnathan.Deezer 

  • Your user id stevezissou27
  • Your offer (Premium, Family...) Premium
  • main country / country where you streams (in case is different) UK (England)
  • played context (Track mixes? search? playlist?...) Playlists, sometimes songs that haven’t been downloaded.

Thank you! 

@Johnathan.Deezer 

Glad to see I’m not the only person to get this error. It’s so frustrating. Restart phone. Uninstall and reinstall the app. Clear cache etc etc. nothing fixes it. What I don’t get is how is this a big that needs fixing when it didn’t use to happen? Surely a previous update caused this. I never understand why companies forward fix major issues instead of regress to a working version

This is still happening as I’m constantly getting this message.

 

like all comments above I have tried everything the app support suggests but nothing happening.

deezer has always been my music app as find it so easy to navigate but this is really putting me off. Constantly having to close and retry the app just to get a song to play.

CERTAINLY not getting many moneys-worth at the moment, especially with the recent increase!

 

sort it out deezer!!!! Please!

I think it’s clear that this isn’t goingbto be fixed anytime soon. Customer service isn’t what it used to be!

I am also getting this error message randomly.  I have to close and reopen the app to play the track. 
 

then a few tracks later the error message will reappear 

 

using latest update from the App Store too 

One other question, @mcbarclay @stevezissou27 @matty.adam.carver @Bmcg... Do you get this error when you were using a VPN or when you were travelling, for example? 

Hi Johnathan.  
 

 No I don’t use a VPN. I did some more fault finding yesterday this was while using WiFi.  
 

a song would display the error.  I would then restart the app, this song would then play. Then the next song would then display the error.  And you then go around in this circle.  

One other question, @mcbarclay @stevezissou27 @matty.adam.carver @Bmcg... Do you get this error when you were using a VPN or when you were travelling, for example? 

I’ve not used a VPN on this

I am constantly getting the error code 2004 it’s a joke considering the issue has been going on for months and they’ve got a cheek to put the monthly subscription up get it sorted 

You’ve been saying for months now that this problem would be getting fixed and like I said before you had the cheek to put up the prices knowing this issue was still ongoing every song I try to get now is coming up with this code it’s a ripoff am now cancelling my subscription 

I keep getting error failed to play ms2004. Happened a few weeks ago and changed cache and was fine after that. Tried reinstalling app signing in and out and making sure got latest update of software and Deezer. Running out of options?! Been with Deezer like years now and never had this problem? 

Just done that and still doesn’t work? It’s not all songs just some of them say error. Don’t know what else to do now