Question

Downloads of favourite tracks get deleted automatically

  • 22 December 2020
  • 13 replies
  • 112 views

Userlevel 3
Badge

Since yesterday, my favourite track downloads were spontaneously deleted. The tracks are still there in my playlist, but the downloads are gone. I’ve already tried deleting smart cache, uninstalling app, rebooting phone and reinstalling the app. The problem is still there. It only happens on the Favourite tracks playlist. My manually created playlist downloads are working perfectly fine.

 

Is anyone else having the same issue?

iOS 14.3 on an iPhone XR.


13 replies

Same issue here. It works fine when I’m on wifi, but when I switch it to 4G it suddenly removes all downloaded ones or at least part of them and eats up all my 4G to when I play them on 4G.

 

So it is not only a visual bug but indeed it deletes all the downloaded data.

I tried removing all downloaded ones and the cache of the app. Re-install the app but non helped at all.

 

iPhone 11 Pro, iOS 14.3, Latest Deezer store version.

I’m afraid this is symptomatic of the current state of Deezer. It’s become very troublesome across a broad front. I’ve lodged several complaints with Customer Services and have been told to wait for an update in January 2021 which will apparently fix everything. My impression is that they’re adding bolt on features all the time, but now failing to get the basics right. You need the option to download music onto your device and it needs to be totally reliable. Deezer seem to think everyone just wants to stream, but on an iPhone that really eats up battery life. They need to get this sorted out or I’m cancelling after 5 years subscription.

Userlevel 5
Badge +2

Hi @teaumaz @aaronsarkissian512 @drb0309  I have been informed by our developers that the problem has been fixed with the latest version of the Deezer app. Can you please update your Deezer app to version 8.29.0 and let me know if it works?
Thanks :relaxed:

Userlevel 3
Badge

Hi @teaumaz @aaronsarkissian512 @drb0309  I have been informed by our developers that the problem has been fixed with the latest version of the Deezer app. Can you please update your Deezer app to version 8.29.0 and let me know if it works?
Thanks :relaxed:

I can confirm that, so far, the problem seems to be fixed indeed. Thanks for the swift turnaround!

Hi @teaumaz @aaronsarkissian512 @drb0309  I have been informed by our developers that the problem has been fixed with the latest version of the Deezer app. Can you please update your Deezer app to version 8.29.0 and let me know if it works?
Thanks :relaxed:

For me it is not fixed, even though the app has been updated…

iphone x ios 14.3

Userlevel 3
Badge

Hi @teaumaz @aaronsarkissian512 @drb0309  I have been informed by our developers that the problem has been fixed with the latest version of the Deezer app. Can you please update your Deezer app to version 8.29.0 and let me know if it works?
Thanks :relaxed:

I can confirm that, so far, the problem seems to be fixed indeed. Thanks for the swift turnaround!


Scratch that. The problem is not fixed

Userlevel 7
Badge +6

Thanks for reporting this @teaumaz @lukatherr 

8.30 is in the oven now. Have you tried to uninstall the app, restart your iPhone and then reinstall the app? Please keep me posted so that I can pass the info to our devs :thumbsup_tone2:

Userlevel 3
Badge

That’s exactly what I did. The problem still persists. Looking forward to when 8.30 is fully baked. It’s already smelling nice in the kitchen *wink*

Userlevel 7
Badge +6

That's the smell of user-centric development @teaumaz :stuck_out_tongue_winking_eye:

In all seriousness, please do keep me posted. 8.30 dropped on my phone today, I really need your feedback!

Userlevel 3
Badge

That's the smell of user-centric development @teaumaz :stuck_out_tongue_winking_eye:

In all seriousness, please do keep me posted. 8.30 dropped on my phone today, I really need your feedback!

The problem is still not fixed Rudi. I can send you a screen recording to show the issue as it is easily reproducible. The forum doesn’t allow for sending videos however. 

Userlevel 7
Badge +6

Hey! @teaumaz 

Could you please try redownloading the tracks to check?

The forum allows for YT videos, but if you have a link I can follow it too!

I managed to get it to work on 8.29 with a restart and reinstall, but as i updated to 8.30 the problem is back, tried to restart and reinstall again but doesnt appear to work...

Userlevel 7
Badge +6

This feedback is precious @lukatherr thanks a lot for sharing, I'll be passing it on :thumbsup_tone2:

Reply