Deezer on Sonos error message: "I am unable to play this right now"

  • 15 February 2019
  • 2 replies

i use deezer on a sonos with Alexa (free 6 month subscription with speaker)

when inrequest a song, it plays but then loses connection and Alexa says “I am unable to play this right now” and stops the song.

I thought it was loss of wireless but Alexa will function normally after sound is lost and other devices are fine too.

I have tried to update all software but can’t find how to update the apps.

It worked fine for the first 6 months after I got the speaker in December.

inam just not 100 per cent sure what is causing the problem from the 3 elements??

2 replies

Userlevel 7
Badge +6
Hi there @epbenham1980

Perhaps you could try reinstalling the Sonos app to their latest version - and also try to update the system itself. For more info, please check this page ;)

Switching off your internet router for 3 minutes and switching back on could help too.
Thanks rudi, I will give that a try 😀