Question

Opera Support



Show first post

39 replies

Userlevel 7
Badge +7
@bluezzbastardzz Great point! I'll pass this on to the team :)

@huwie Let me check with the team again if there are any plans to change this in the future. We don't have any details at the moment, but we hope we'll have something for you soon 🙂
Another company pushing Google over other versions based on chrome, its called a monopoly people, probably find deezer get higher page ranks by pushing google chrome over other versions..
Hello, I have already installed flash player but when I want to listen to music in Opera I receive a notification asking me to install Flash Palyer. Also, I dont have an option to turn on HTML 5, but several month ago I could have done it.
Userlevel 3
Badge
Deezer currently does not officially support Opera.
Users have found ways around that fact though:
https://www.reddit.com/r/deezer/comments/8cxobm/deezer_on_opera_tries_to_use_flash_no_html5/

Apart from that you can always use a different supported browser (Chrome, Firefox, Safari) or install the Deezer App.
Changing user agent works. Thanks!
Userlevel 7
Badge +7
Another company pushing Google over other versions based on chrome, its called a monopoly people, probably find deezer get higher page ranks by pushing google chrome over other versions..

Hi there, I understand that this can be frustrating and we have let our team know that this is something that users want. We are not pushing Chrome over other browsers. We always handle all very popular/ most used browsers simultaneously, including Firefox and Safari. But as everywhere else, our resources are limited, which is why we can't always make all users happy.

We don't have any concrete plans for opera as of yet, but we'll let you know, should there be an update. And the community moderators won't give up. We'll keep in touch with the team regarding this to make sure, this is not being forgotten about. Have you created a topic on our ideas forum for this? It's always best if we can share numbers with the team. If they see that a lot of users vote for a certain subject, priorities or elements on our roadmap might change.
Userlevel 3
Badge +1
@Anja: thank you for your response.

However, it simply isn't good enough. Technically Deezer works just fine on Vivaldi, Opera, and any browser which supports HTML5 (in other words, all of them). The web player isn't working on Vivaldi right now because you are intentionally blocking it. It was fine a few days ago. Youtube works, Spotify works, pretty much any other website that streams content works. Deezer is the only one that doesn't.

If your developers don't stop blocking Vivaldi I will switch to Spotify, simple as that.
Userlevel 6
Badge +5
Have you created a topic on our ideas forum for this? It's always best if we can share numbers with the team. If they see that a lot of users vote for a certain subject, priorities or elements on our roadmap might change.

Why not simply move either this thread or one of the other related threads over to the Ideas forum, maybe changing the subject to "Support Opera on Deezer" or similar?

Anyhow, here are the related threads sorted by date:

https://en.deezercommunity.com/troubleshooting-and-tips-4/flash-doesnt-work-in-opera-11042

https://en.deezercommunity.com/troubleshooting-and-tips-4/cant-play-any-song-because-of-that-annoying-message-adobe-flash-player-on-opera-required-10892

https://en.deezercommunity.com/troubleshooting-and-tips-4/where-the-html5-player-disappeared-8713

https://en.deezercommunity.com/forum-em-portugues-24/problemas-com-o-adobe-flash-player-no-opera-8683

By the way, the option in your settings to enable HTML5 comes back if you use the user-agent switcher add-on mentioned before. And it seems to work, too, also with video ads.😇
Hello. Of course, I'm sorry, but this answer stupid "we do not support opera." This browser is used by hundreds of thousands of people around the world, and you can not do anything about it !? People pay you money for using Deezer. This is not the first time such a thing, at first somehow it became unnoticeable for me, it's normal again, now again the same situation. You are going to somehow solve this problem. You have to listen to music in the PC application, but it's so raw that you can not use it anyway, it's better to use a mobile application, there are no pritensions for it, you really improve it and you can see that you are changing it for the better. What can not be said about the application on the PC. Deezer I've been using for more than 2 years, and I've always used only opera or iphone, there have never been any problems. Do something already with the above problems, because it worries how I understood not one of me, if you really value your users. Thank you
Hi. Of course, I'm sorry, but this answer stupid "we do not support opera." This browser is used by hundreds of thousands of people around the world, and you can not do anything about it !? People pay you money for using Deezer. This is not the first time such a thing, at first somehow it became unnoticeable for me, it's normal again, now again the same situation. You are going to somehow solve this problem. You have to listen to music in the PC application, but it's so raw that you can not use it anyway, it's better to use a mobile application, there are no pritensions for it, you really improve it and you can see that you are changing it for the better. What can not be said about the application on the PC. Deezer I've been using for more than 2 years, and I've always used only opera or iphone, there have never been any problems. Do something already with the above problems, because it worries how I understood not one of me, if you really value your users. Thank you so much for attantion
Just because you don't officially support a browser doesn't mean you have to intentionally block it or force it to use a deprecated proprietary plugin. In fact, ironically, by blocking a browser, you're into answering more support tickets and forum posts than if you just treated it the same as Chrome.

Here's my suggestion:

1) Just drop flash completely. Delete all references to it from your codebase. All major browsers have fully supported HTML5 audio since 2011. This will in fact simplify things for you overall. Even just testing for HTML5 support is ridiculously simple. This is mid-2018. Adobe will officially drop flash completely by 2020, so the clock is ticking. Facebook has supported HTML5 since 2015, Youtube dropped flash all together in favor of HTML5 last year.

2) If a user connects using an unsupported browser, display some sort of pop-up or modal overlay or however you want with a simple message:

Hey, it looks like you're using the FarmHouse LightningSpeed Hipster2 Browser version 0.62.21. Unfortunately we do not officially support your browser at this time. You may continue to use Deezer as-is, however some features may not work exactly as intended. We recommend X, Y and Z browsers with Deezer as these have full support. [Accept]

3) And then just serve the content the same way as you would any other browser. Don't block any of your site's features from any browsers. Don't maintain two sets of code, but be upfront when a minority browser may not work on your website. This way you don't have to officially support a browser, but you also keep your support tickets (and forum posts) to a minimum.


You're only doing yourselves and your users a disfavor by forcing some deprecated legacy technology on them because you don't consider their browser to be supported. If anything, the default should be to err on the side of making your code more modern, not forcing legacy. Then if you only want to support browsers that have HTML5 audio player, just do it. If someone is using a browser that doesn't have HTML5 audio, too bad for them; time to uninstall Netscape Navigator.

Just my $0.02.
Userlevel 7
Badge +4

Why not simply move either this thread or one of the other related threads over to the Ideas forum, maybe changing the subject to "Support Opera on Deezer" or similar?

Hey there, I've done that just now :)

It's been moved to the ideas forum and hopefully more people can vote for it to make our developers see the need to support Opera.

Thanks for gathering all the threads, @bluezzbastardzz. Great help 😘
The problem seems to be fixed now (at least for Opera & Vivaldi)

Please buy the web developer in question a beer and remind him not to mess it up again.

Thank you!.
Userlevel 6
Badge +5
Thanks for reporting, at the moment it also works for me without changing the user-agent ID. It would be good if this is confirmed as a working support for Opera by the moderators, too. And also change the related FAQs about browser support etc.

Reply