Crackling, skipping and quality issues via chrome cast when streaming

  • 21 September 2018
  • 14 replies
  • 1451 views

Userlevel 2
Badge
As per the title, there are quality issues when streaming via chrome cast (I have hifi account). It is like listening to a damaged CD.

Note I am streaming, not playing downloads from the SD card as I see this has been offered as the reason elsewhere for similar issues.

It is intermittent. Sometimes an issue with all tracks for a listening session. Sometimes 1 or 2 only. Sometimes no issue.

I have fast internet (fine for 4k TV streaming) and sting wifi. That is not the problem.

14 replies

I'm also experienced similar issues when casting to Chromecast.

When skipping few song, the sync is lost, different song on Android and Chromecast.

This requires restart both Chromecast "home" app and Deezer app.
Userlevel 2
Badge
Same here regarding the disconnects and restarts. Have usually had to force-stop deezer or restart my phone to resolve.
I have experienced the same issue quite a few times...
sometimes even only at the end of a track it sounds like a bad CD RIP!

ie, Check this album: "Taffetas - Taffetas (2005)"
I think ALL tracks are damaged with skipping and clicking sounds.

What's up with that? :S
Hello dear Beta users!

We're very sorry to hear that some of you are experiencing troubles with Google Cast experience in our Android app :-(

We're currently investing a lot of efforts to improve integration of Google Cast within our apps. Many stability improvements have already been released in the last version 6.0.1.48 currently in production and more is to come in upcoming beta :-)

In order to investigate your issues, we need you to provide us with detailed information about the version of the Android Application you're using and the model of Chromecast you're casting to.
Hello dear Beta users!

We're very sorry to hear that some of you are experiencing troubles with Google Cast experience in our Android app :-(


These erorrs are NOT only in the Android app. They are also on the internet! Try listening in Chrome or Firefox or anywhere else.

Here is another: https://www.deezer.com/en/track/63983500
This track cuts off one minute too early.
Userlevel 2
Badge
Hello dear Beta users!

We're very sorry to hear that some of you are experiencing troubles with Google Cast experience in our Android app :-(

We're currently investing a lot of efforts to improve integration of Google Cast within our apps. Many stability improvements have already been released in the last version 6.0.1.48 currently in production and more is to come in upcoming beta :-)

In order to investigate your issues, we need you to provide us with detailed information about the version of the Android Application you're using and the model of Chromecast you're casting to.


Hi,
experiencing the same - Android 8.0 on Samsung S9+ (but same issue on Xiaomi Mi Max 2 Android 8.1)

Deezer 6.0.3.24

As mentioned in the posts above - sounds sometimes like a broken record. And also sporadically having the issue that songs skip to the next one after 30sec (I am Hifi subscriber)

Chromecast via desktop streaming (Mac OsX 10.14) and "Airfoil 5.8.3" works very well and without any problems!

Streaming to a Chromecast Audio

The goal is to be able to comfortably stream HIFI (!!) quality throughout my house via Android

So the end-to-end experience is:
1) You fire up Deezer on Android (Hifi!) - start playing a song
2) Sit down on your PC or Mac - fire up Deezer (you see what's playing) - switch to another song
3) Get to the kitchen and use your mobile (Android or ioS) and skip to the next song

Guys, this is not rocket science - just look at how Spotify is doing it - I love Deezer, but without this I think you will loose many Hifi subscribers the second Spotify enters with a Hifi offering

Good luck!
Problem with Chromecast audio here 😞
Hey there !
Because the problem is still there, I'm digging up this thread.

First of all: the problems (or atleast most of them) in the app are both in the stable and the beta version, I fully reset my phone and my Chromecast Audio recently, I tried on both HQ and standard quality (standard quality seems to have less microcuts), all the songs are downloaded, my internet connection is quite good (30 MBits/s, largely enough for Deezer) and finally, my Chromecast is (litterally) placed at 20 cm from my router.

So here are all my problems (and some missing features):
Deezer website:
  • Sometimes there is microcuts while playing a music (same as Bluetooth interference)
  • While casting a song, the "Play" button on top of a playlist changes to the "Listening" animation, but there is no animation nearby the song in the list. (see picture).


  • If I remove a song in the queue, the music information displayed (Cover, artist, title, album) are the one of the song that Deezer should normally be playing, but the music actually playing is the one that has been removed from the queue (and so the entire list is out of sync with what is displayed)
  • Can't play a playlist randomly
Deezer app:
  • Sometimes there is microcuts while playing a music
  • Sometimes there is an infinite loading while trying to cast a song, even after changing the song. The only way I've found to make it works again is to completely close the app, and try again (I might have to do it multiple times before it starts working again)
  • When I cast a song in a playlist, the playlist gets completely random, and when refreshing it, leaving then returning in the playlist or change the song, it will sometimes do nothing, or change the songs displayed in the playlist (see pictures, as it can be quite confusing the way I'm explaining it 😄).[img]https://d1uyvls174j03l.cloudfront.net/deezer-en/attachment/ae41a781-bb0b-4e7f-9d54-f56f12dcc3e3.jpg[/img][img]https://d1uyvls174j03l.cloudfront.net/deezer-en/attachment/95e14ce1-9eaf-4dba-96d7-afa6d637f86c.jpg[/img][img]https://d1uyvls174j03l.cloudfront.net/deezer-en/attachment/837073cb-df4a-40bf-925f-fcf285ad761d.jpg[/img]
  • Can't play a playlist randomly, nor modify the waiting queue.
  • While playing an "Inspired by" playlist, in the "Now playing" screen, it acts as a normal playlist, but while casting, it acts as the Flow (can't go back, both using Previous button or by sliding the cover, no "Random" nor "Repeat" button, and the "add to playlist" button is replaced by the "I Don't like" button). (see pictures)


  • When playing a song by clicking on it (not using next/previous on the "Now playing" screen), the "Next" button is greyed and can't be clicked on until the song is loaded. (see picture)


And there you go ! Hope you guys fix all theses issues as fast as you can, as I sometimes want to destroy my phone/computer because of them 😅.
I forgot to mention another issue (and now it's too late to edit my comment):
In the app, if there is a music manually uploaded to Deezer in the waiting queue, when it will be reached, the song will be skipped, so on the "Now playing" screen, all informations displayed relate to the song next to the skipped song, but the music actually playing is the one after.
Example: In a playlist with music A, B, C and D, if B has been uploaded by myself, after playing A, informations displayed on "Now playing" screen (and everywhere else in the app) are the one of the song C, but the music actually playing is the D.
I'm adding another bug to the (long) list:

I have "null" songs on my playlist (while casting as always). It acts as a mp3 song (when you click on it, the informations displayed skip to the next song, but the music being played is still after.

I don't know where the "null" songs come from (as my MP3 songs appear like any other song).

Because using the cast function in Deezer looks like activating the very first pre-alpha version (I'm sorry but it's true), I tried to find a link between the number of "null" songs before the song playing (which would shift everything), but it starts well and then it became a bit random:

Starting from the end, from the first to the 27th songs, they all play fine, from the 28th to the 37th, they all play the same song that is normally in the playlist, but not on "this" playlist (I previously forgot to add that, with the "random music order" issue, when using the cast (and only, after disconnecting everything is back to normal), a lot of songs are removed from the playlist). Then it's shift from 8 songs (the 30th songs plays the 22nd...), and then the shift is slowly reducing, quite randomly (not dependent of the number of "null" songs in between), sometimes getting some shift again, then reducing until the songs between the very end and the last "null" song, where there is no more shift.

I've already tried different things (stop casting, force stop the app, restarting my phone...), and then trying it again, when the playlist was different (as the playlist are randomized while casting) I simply leave it then returning in it again, and then the playlist was back to the same buggy order as before, so I tried my test again, and it was like the first time for the one I precisely describe (from the first to the ~40th, and from the end to the last before the first"null" song encountered). Others were sometimes more or less shifted.

Hope this is the last bug, please do something guys, it's one of the only bug (if I put every bugs related to the chromecast in one, the ultimate issue) I have (both in stable and beta version). It's like for requested functionnalities (dark mode for example 😏), it's getting old and necessary, but nothing has been done for now.

Ps: for one of the screenshot, the circle indicates the music being played instead of the one displayed, for the other one, I couldn't edit it but it was Move Along (the second starting from the bottom).
When i cast to my Chrome cast it ONLY plays 20 sec in the Middle of Every song.. wonder if we should quit This and go to Spotify, event tough i dont like it.. PLS fix it, or i will chance.. VERY SOON!
Only a problem when casting to Chrome cast..
Also experiencing the micro drop outs, random stops, slow track starts & disconnects casting from android to Chromecast audio.

What I'm using...
Deezer Hifi, although this happened with premium too. Beta App version 6.0.7.97
Sony xperia z5 android 7.1.1
Chromecast audio using firmware 1.37.146679
100meg down internet connection

I also have the ccaudio grouped multiroom via cast with a sony x77 wireless speaker. When used grouped the ccaudio will randomly drop out while the x77 doesnt. Really hope that this can be resolved
To add to above after continued listening the x77 does drop out too, just nowhere near as much as the Chromecast audio

Reply