Answered

Error: Failed to play. The requested content is not loading


Ive downloaded my music on favourites but sometimes my music qont play it gives me a error message of Error Faild to play then says content loading ans when you retry it doesnt want to play. At some stages songs play like scratched cd ive updated the app even download songs using data.
icon

Best answer by Pia.Deezer 2 March 2020, 17:03

Hello @Pigherder @IvánCortés @nweze @Neon.Tetras @Minion2 we are very sorry to hear you are experiencing this issue. Please bear in mind that listening to music is using loads of data. In case the issue only happens with mobile data, try strong Wifi or make sure your music is downloaded for sure.

Otherwise, could you please perform all of these troubleshooting steps again, exactly in the order mentioned. Otherwise it does not fix it.

Please keep in mind this will remove any downloaded songs on this device, but you can easily download them again afterwards, from your Favourites.

  1. Click on My Music/Favourites (the little heart) >>> Gear Wheel JiE3V4t.png>>> App Settings >>> Smart Cache>>> slide the blue button towards the middle of the line.
  2. If you are using the battery saving mode on your device please turn it off for once and try to test Deezer again.
  3. Click on My Music/Favourites (the little heart) >>> Gear Wheel JiE3V4t.png>>> App Settings >>> Disc Usage >>>Clear All
  4. uninstall Deezer
  5. remove the SD card
  6. restart your phone
  7. reinstall Deezer (available on Google Play)
  8. open Deezer and download at least one album or playlist and play one song
  9. reinsert the SD card

This should fix the issue but please let me know if you need any further help :slight_smile:

View original

This topic has been closed for comments - the content may no longer be relevant or up-to-date, so please search for keywords so that you can find a newer post or look below for a direct link

277 replies

When listening to tracks it keeps saying "Failed to load content"
Userlevel 7
Badge +1
Hi @Joanna.Annerson and welcome to the community! 👋🏻 What device do you use and do you have the issue on wifi and mobile network?
Ive downloaded my music on favourites but sometimes my music qont play it gives me a error message of Error Faild to play then says content loading ans when you retry it doesnt want to play. At some stages songs play like scratched cd ive updated the app even download songs using data.
Userlevel 1
Hi,
I keep getting the Error: Failed to play: The requested content is not loading.
This just started recently on my Android phone (Moto Z Play). And only occurs on a specific mobile network. Works fine on WiFi as well as when I switch to another mobile network.
But I have been using the same network for years and this error only started a recently.
Any ideas on what I should try. I have scoured through the settings (App and Audio) but nothing helps.
Hi. Im the same last few days. O van listen to downloaded music but will no longer stream with error message of " the requested content failed to load". Same on 4g and wifi. I have family pass and all accounts are the same.
Userlevel 7
Badge +1
Hi @Rogers Baguma, this seems like an issue with the network itself. How did you switch to another mobile network? What the provider?
Userlevel 7
Badge +1
Thanks for the info 🙂 But does this happen on all devices or just on yours? Also what model is it?
I inserted a new memory card into one of my other profiles devices. I lost all my downloaded content. Now i recreated the account but the first album i downloaded still shows error: failed to play'- the requested content is not loading
Same error on mobile network and wi-fi. Its not a first time. Just befor it was for 2-3 days.
I have premium+ with no internet limits on mobile network.
I can use only downloaded music. All week i see this error. 1, maybe 2 songs per day and again..

I delete deezer from other device. So only one phone, 9euro per month and i forced listening radio.
Absolutly disaster...
Userlevel 3
I have the same problem with a certain mobile network (it's called Zain, Jordan) where I get "the requested content failed to load", only on the Android app, the browser player works fine. Tested on several phones. Using a different internet provider (Orange Jo), the Deezer app works fine.

Other music streaming apps also work fine, it's only Deezer and only on a specific network. I've heard on other local forums that other users are having the same problem. I contacted the ISP and asked them and they said to contact Deezer instead as they have no knowledge of this problem.
Userlevel 7
Badge +1
@Simonas.Gr., and have you tried to increase the size of the smart cache? Also if you are using a sd card in the device, this might also cause the problem. Please try those steps first and let me know if that helped.
Userlevel 7
Badge +1
@wikhatib Thanks for the info. I'm happy to check with our team, but it is possible that the network provider is blocking Deezer. I'll let you know if I have any updates ☺️
Userlevel 7
error: Failed to play
Hi @Gugu Gwala I moved your comment to this topic where some users were talking about it too. 🙂
I downloaded deezer tonight and start downloading albums but in half they stop to download,i marked all albums but only half of them downloaded. When i try to play song they show me this picture. Thank you

Hi I have got the message of ‘the requested content is not loading.please retry..
I used to can play the song n don’t know why suddenly all songs appear this message.. what is going on?
I was I in Australia two days ago, and I just arrrived Hong Kong and suddenly the songs appear this message.. can anyone please advise how?
Userlevel 7
Badge +1
Hi @Esther Lee, please go to app settings and increase the size of the smart cache and restart the app. I that doesn't work, are you using a sd card in the device?
Hi @Anja

I am using iPhone 7+ and using both wifi as well as network, I have increased the size of the smart cache, I restarted the phone I also have reinstall the app too., it doesn’t work.. it keep ask me subscribe to download, I tried to switch to download but it didn’t allow me 😭😭😭
Hi@Anja
Is it not available in HK that is why? Or?
The download button not allow me to on at all..
Hi guys.
Why can't I stream or download songs after subscribing to the premium+?
The error message is 'the requested content is not loading'.
Please help
Userlevel 7
Badge +1
@Esther Lee, that's not an issue related to this topic. You are still a free user. Did you pay for Premium+ and if so, did you receive a confirmation for the payment?
Userlevel 7
Badge +1
Hi @emmanuel.yaovi, on what device does this happen? And does this happen on wifi and on mobile network?
Userlevel 3
Not sure why, but after months of this app not working, I tried it again after posting in this thread 5 days ago and now it worked for the first time.
Userlevel 7
Badge +1
@wikhatib, that's great news! 🙌🏼 Let us know, should this happen again 🙂
They requested content is not loading.
Userlevel 7
Badge +1
Hi @Itzik Amar , on what device does this happen?