Question

Deezer pauses mid-track on Android.

  • 17 October 2021
  • 3 replies
  • 39 views

I started having problems with Deezer these past few days.I'm listening to a song and then it pauses in the middle of the song.It happens whether or not I'm using earphones so I know it's not linked to any of my headsets.I tried clearing cache first,  deleted the app, restarted my phone and reinstalled the app but no luck.

I don't have battery saver mode activated on my phone so Deezer does not go to sleep or anything.I'm literally using the app, it's there active on my screen and then suddenly a minute or two into the song it pauses out of nowhere.I just have to press play again because the app is already open on the screen - it's not even frozen.It happens with every song I play.What else do I do?

I use Android version 11.


This topic has been closed for comments - the content may no longer be relevant or up-to-date, so please search for keywords so that you can find a newer post or look below for a direct link

3 replies

Userlevel 5
Badge +1

Hello @Fari S 

We are sorry to hear that. Does that happen with a specific album/song/artist? Or is just a general issue?

It sounds like it could be some cache issue. If you have an SD card can you please follow these few steps:

  1. Open the Deezer app ➡ Gearwheel in the top right corner ➡ Data & Storage ➡ Disk Usage ➡ click on the path link and change it to internal storage
  2. Stream a couple of tracks on Deezer


If it works, the issue is likely with the current SD card. I suggest that you insert a new or different SD card after uninstalling Deezer on your device. Don't worry your playlists and favourites won't be affected.

Once you inserted the new SD card, install the Deezer app again, log in to the app, and stream at least a couple of tracks. You can change the Deezer path back to the SD card, should you wish.

Thanks! :)

Hi it actually happens with any song I play. It pick and chooses when to work so not sure why that happens. I actually don't have an SD card slot in this phone. I also tried clearing all data but not luck. 

Userlevel 7
Badge +4

@Fari S I am sorry that you are still experiencing problems with the app.
Can you please try the following steps one by one and test if it works after each step?

  1. Restart the app (kill the app and remove it from the notification bar)
  2. Try another network (4G or Wifi)
  3. Restart your phone
  4. Delete all the cache & data from the app (Data and storage, and then “Clear all”), then restart the app
  5. Un-install the app and re-install the app

Please let me know if that works. :nerd: