Deezer on Galaxy Tab S7-Cannot run in Browser or Install App

  • 5 December 2021
  • 3 replies
  • 23 views

I have an old Deezer account (free) that I never used. I want to seriously explore streaming at this point. I can log in from a browser in my Galaxy Tablet S7, but I cannot find an option to Play anything. But often various websites treat my S7 as  just a mobile device, so I just went to Google Play and tried to download/install the mobile app. And that fails with the message "something went wrong. Try again."

This is not a good start. Is there a solution?

Thx

Dave

Ps. I tried a couple other Google Play hosted apps, including Amazon Music .  No install problems other than Deezer.


This topic has been closed for comments - the content may no longer be relevant or up-to-date, so please search for keywords so that you can find a newer post or look below for a direct link

3 replies

Looks like a Google authentication problem.  dave

Userlevel 5
Badge +2

Sorry @DaveLeeNC did you manage to download the app? 

 

@Yula Thanks for the follow-up. I simply logged into the second of my two Google accounts and that fixed the issue. I have never had to do that before with Google Play. It is resolved. 

 

dave